Logstash Not Running - No errors in the logs


#1

When running logstash with the xml filter below I get the following output every second:

[2017-07-26T12:56:16,546][DEBUG][logstash.inputs.file ] _globbed_files: C:/U
sers/gpadmin/Downloads/icd10cm_index_2017.xml: glob is: ["C:/Users/user/Downl
oads/file.xml"]
[2017-07-26T12:56:17,257][DEBUG][logstash.pipeline ] Pushing flush onto p
ipeline

Is it running? I see no errors in the logs. Is xpath incorrect?

xml {
source => "message"
store_xml => "false"
remove_namespaces => "true"
xpath => [
"/ICD10CM.index/version/text()", "version",
"/ICD10CM.index/title/text()", "title",
"/ICD10CM.index/letter/title/text()", "letter",
"/ICD10CM.index/letter/mainTerm/code/text()", "code",
"/ICD10CM.index/letter/mainTerm/title/text()", "expression",
"/ICD10CM.index/letter/mainTerm/title/nemod/text()", "nemod",
"/ICD10CM.index/letter/mainTerm/seeAlso/text()", "seeAlso",
"/ICD10CM.index/letter/mainTerm/term/title/text()", "termExpression",
"/ICD10CM.index/letter/mainTerm/term/code/text()", "termCode",
"/ICD10CM.index/letter/mainTerm/see/text()", "see",
"/ICD10CM.index/letter/mainTerm/term//term/text()", "terms",
"/ICD10CM.index/letter/mainTerm//term/text()", "term",
"/ICD10CM.index/letter/mainTerm/term/term/seecat/text()", "seeCat",
"/ICD10CM.index/letter/mainTerm/term/seeAlso/text()", "termSeeAlso",
"/ICD10CM.index/letter/mainTerm/manif/text()", "manif"
]
}


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.