Logstash-output-elasticssearch on Windows cannot load Java class

I started to implement ELK on windows.I got error

C:\logstash\logstash-2.3.4\bin>logstash -f logstash-simple.conf
io/console not supported; tty will not be manipulated
ā†[31mfetched an invalid config {:config=>"input { stdin { } }\noutput {\n elast
icsearch { host => localhost }\n\n stdout { codec => rubydebug }\n}\n", :reaso
n=>"Couldn't find any output plugin named 'elasticsearch'. Are you sure this is
correct? Trying to load the elasticsearch output plugin resulted in this error:
cannot load Java class org.apache.http.\xFDmpl.client.StandardHttpRequestRetryHa
ndler", :level=>:error}ā†[0m
The signal HUP is in use by the JVM and will not work correctly on this platform

config file here:

input { stdin { } }
output {
elasticsearch { host => localhost }
stdout { codec => rubydebug }

When I remove elasticsearch section, works fine.

I try this list but not solve problem:
-Update Java JRE
-Update Logstash-output-elasticssearch
-Reinstall Java JRE
-Reinstall Logstash-output-elasticssearch
-Install JSE instead of JRE
-Convert Java Home 64bit to 32bit

That's not a valid config anyway, see https://www.elastic.co/guide/en/logstash/current/plugins-outputs-elasticsearch.html#plugins-outputs-elasticsearch-hosts

thanks for reply. I changed to default empty config.
error continues

input { stdin { } }
output {
elasticsearch { }
stdout { codec => rubydebug }

It is because of the regional setting of the windows server (Most probably Turkish)
the plugin tries to load org.apache.http.impl.client.StandardHttpRequestRetryHa
ndler, with lowercasing the the letter (I) resulting in character (Ć½) /xFD. You can workaround the problem by changing the region of the server to another region like English(US).

1 Like

thank you so much.
this is a good lecture that don't try new technology on local windows instead of universal jvm.