Logstash-plugin install failed


(Arun Prasath) #1

I am trying to install output plugin using below command but it has failed saying there is no connection. But I tried to download and able to download using wget. I have extracted the download .gz file and it is a data file. How to install with the downloaded file manually. I believe it could be possible to install using local downloaded file. If this is not possible, what other options to debug and install the output plugin.
Please advise me.

./logstash-plugin install logstash-output-email
Validating logstash-output-email
Unable to download data from https://rubygems.org - Errno::ECONNREFUSED: Connection refused - Connection refused (https://api.rubygems.org/latest_specs.4.8.gz)
ERROR: Installation aborted, verification failed for logstash-output-email


(Magnus B├Ąck) #2

Perhaps you need to configure logstash-plugin to use your HTTP proxy?


(Arun Prasath) #3

I found these export options.
export http_proxy=http://proxy.server:3128
export https_proxy=http://proxy.server:3128
export JRUBY_OPTS="-J-Dhttp.proxyHost=proxy.host -J-Dhttp.proxyPort=3128"
Is the port 3128 is the default one or I have get this from the administrator ? Is there any other options to install manually ?


(Arun Prasath) #4

Hi Magnusbaeck @ My logstash process is spawning new process id every few seconds and my logstash is not started properly. This behavior has started since I tried to install the output email plugin. From the /var/log/messages/logstash-stderr.log file I see the following error message. Any thing that I can do to resolve this error ? this is the working system.

Bundler::GemNotFound: Could not find gem 'logstash-output-email (>= 0) java' in any of the gem sources listed in your Gemfile or installed on this machine.
verify_gemfile_dependencies_are_found! at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:328
each at org/jruby/RubyArray.java:1613
verify_gemfile_dependencies_are_found! at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:307
start at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:199
resolve at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:182
resolve at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:192
specs at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:132
specs_for at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:177
requested_specs at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:166
requested_specs at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/environment.rb:18
setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:13
setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler.rb:122
setup! at /usr/share/logstash/lib/bootstrap/bundler.rb:64
(root) at /usr/share/logstash/lib/bootstrap/environment.rb:64
Bundler::GemNotFound: Could not find gem 'logstash-output-email (>= 0) java' in any of the gem sources listed in your Gemfile or installed on this machine.
verify_gemfile_dependencies_are_found! at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:328
each at org/jruby/RubyArray.java:1613
verify_gemfile_dependencies_are_found! at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:307
start at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:199
resolve at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:182
resolve at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:192
specs at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:132
specs_for at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:177
requested_specs at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:166
requested_specs at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/environment.rb:18
setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:13
setup at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler.rb:122
setup! at /usr/share/logstash/lib/bootstrap/bundler.rb:64
(root) at /usr/share/logstash/lib/bootstrap/environment.rb:64
Please advice.


(Arun Prasath) #5

created a new issue since http_proxy settings are required for this issue and errors state it is due to Bundler::GemNotFound and it is new issue. Thanks Magnus.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.