Logstash service fails - OpenSSL X509 StoreError


#1

Hello,

I've noticed the logstash service fail on each start.
logstash.err shows:

> OpenSSL::X509::StoreError: setting default path failed: IOError
>   set_default_paths at org/jruby/ext/openssl/X509Store.java:185
>              (root) at /opt/logstash/vendor/jruby/lib/ruby/shared/jopenssl/load.rb:26
>             require at org/jruby/RubyKernel.java:1040
>              (root) at /opt/logstash/vendor/jruby/lib/ruby/shared/openssl.rb:1
>             require at org/jruby/RubyKernel.java:1040
>              (root) at /opt/logstash/vendor/jruby/lib/ruby/shared/openssl.rb:1
>             require at org/jruby/RubyKernel.java:1040
>              (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/patches/stronger_openssl_defaults.rb:1
>             require at org/jruby/RubyKernel.java:1040
>              (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/patches/stronger_openssl_defaults.rb:2
>             require at org/jruby/RubyKernel.java:1040
>              (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/patches.rb:1
>             require at org/jruby/RubyKernel.java:1040
>              (root) at /opt/logstash/lib/bootstrap/environment.rb:69

I ran logstash manually as root and it runs well.
I've also copied the exact command running when the service starts using ps -ef and tried it as well.
I've enabled login to logstash and tried running the same command, and I got an error. Adding the user to the root group did not help. I'm guessing it is either a permission problem or an environment variable that is not configured well, and would appreciate any help or idea I could check.

Thank you.


(John Claudias) #2

I am receiving the same issue and can't find any solutions to this issue.


#3

same issue on my side.
has anyone of you found a solution yet?


(system) #4