Logstash Service starts but it could not work without manually starting with --path.settings and -f parameters

Hello,
I have a problem with Logstash, I want to start it on startup. It seems it works as a service but it can not work essentially. When I run /usr/share/logstash/bin/logstash -f /etc/logstash/conf.d --path.settings /etc/logstash, it works perfectly but I want to work it as a service. I changed /etc/systemd/system/logstash.service file ExecStart part /usr/share/logstash/bin/logstash "-f /etc/logstash/conf.d" "--path.settings" "/etc/logstash". I tried all solutions that have similar topic with mine. So, is there any idea about why Logstash does not work as a service at startup?

P.S. : When I look logs with journalctl --unit logstash, it shows that
No config files found in path {:path=>/ /etc/logstash/logstash.conf"}
No configuration found in the configured sources.

Hi,
I am also having trouble getting Logstash to startup as a Service. NSSM installs the service under Windows, but, the service will not start.

PS C:\Windows\system32> Start-Service -Name "Elasticsearch Logstash 7.3.2"
Start-Service : Failed to start service 'Elasticsearch Logstash 7.3.2 (Elasticsearch Logstash 7.3.2)'.
At line:1 char:1

  • Start-Service -Name "Elasticsearch Logstash 7.3.2"
  •   + CategoryInfo          : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
     ServiceCommandException
      + FullyQualifiedErrorId : StartServiceFailed,Microsoft.PowerShell.Commands.StartServiceCommand
    
    

Does anyone have any idea why this is happening ??
Cheers,
David