Logstash TCP json_lines to elasticsearch won't stop printing output to stdout


I am using the logstash docker image and a pipeline from tcp to elastic search. Whenever a message is processed by logstash it is also output to stdout, even though I have logging turned to warn or above. There are no error messages, only the processed message which is sent to elasticsearch.

Is there any simple way to disable this logging to stdout?

Here are my pipeline and settings yml

input {
  tcp {
    port => 8001
    codec => json_lines

filter {
  mutate {
    add_field => {
      "server_time" => "FAILED"

  date {
    timezone => "UTC"
    match => [ "[doc][time]", "UNIX_MS" ]
    target => "server_time"

output {
  elasticsearch {
    hosts => ["elasticsearch"]
    index => "tcp_log-%{+yyyy.MM.dd}"

    size: 500
    delay: 25
  workers: 16
  debug: false
  level: error

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.