Logstash: TCP output with tls is not working


(Mahesh) #1

Hello,

I am trying to send events over secure TCP from logstash but facing issues with ssl settings:

Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<OpenSSL::PKey::RSAError: Neither PUB key nor PRIV key:>

Here is my config:
tcp {
port => 11111
host => "xx.xx.xx.xx"
ssl_enable => true
ssl_cert => "cert.crt"
ssl_key => "key.pem"
ssl_verify => false
codec => json_lines
}

I have generated ssl certificate from server using below commands:
openssl pkcs12 -in pathto_mykeystore/keystore.p12 -out cert.crt

and key using(it's a private key as I can see it in the output file):
openssl pkcs12 -in pathto_mykeystore/keystore.p12 -nocerts -out key.pem

Am I missing something here?
help/suggestions appreciated


(Mahesh) #2

any inputs here?


#3

Have you tried a full path to the key/cert pair?


(Mahesh) #4

yes. As paths are internal to product so not mentioned as is.

also tried with ssl_key_passphrase=<actual_password>


(Mahesh) #5

@ceekay anything else that I am missing here?
does logstash support all types of ssl certificate/keys or specific is supported like only X509


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.