Logstash to logstash with SSL and lumberjack plugin

Hi,

I try to send data from logstash to another logstash. I followed this doc ofc https://www.elastic.co/guide/en/logstash/6.6/ls-to-ls.html but it didn't work. here is my configuration:

On the recieving server:

beats {
                codec => json
                port => 5443
                ssl => true
                ssl_certificate => "/appl/elk/logstash/conf.d/ssl/SERVER_NAME.com.cer"
                ssl_key => "/appl/elk/logstash/conf.d/ssl/SERVER_NAME.com.key"
                client_inactivity_timeout => 360
        }

on the sending logstash:

input {
        beats {
                port => 5044
                client_inactivity_timeout => 360
        }

}

output {
        lumberjack {
                codec => json
                hosts => "parser01-hawkeye.com"
                ssl_certificate => "/appl/elk/logstash/conf.d/ssl/SERVER_NAME.com.cer"
                port => 5443
        }
}

and when I start the sender here is what I got :

[ERROR][logstash.outputs.lumberjack] All hosts unavailable, sleeping {:hosts=>["10.124.70.189"], :e=>#<OpenSSL::SSL::SSLError: Connection reset by peer>, :backtrace=>["org/jruby/ext/openssl/SSLSocket.java:266:inconnect'", "/appl/elk/logstash-6.6.1/vendor/bundle/jruby/2.3.0/gems/jls-lumberjack-0.0.26/lib/lumberjack/client.rb:95:in connection_start'", "/appl/elk/logstash-6.6.1/vendor/bundle/jruby/2.3.0/gems/jls-lumberjack-0.0.26/lib/lumberjack/client.rb:76:ininitialize'", "/appl/elk/logstash-6.6.1/vendor/bundle/jruby/2.3.0/gems/jls-lumberjack-0.0.26/lib/lumberjack/client.rb:34:in connect'", "/appl/elk/logstash-6.6.1/vendor/bundle/jruby/2.3.0/gems/jls-lumberjack-0.0.26/lib/lumberjack/client.rb:24:ininitialize'", "/appl/elk/logstash-6.6.1/vendor/bundle/jruby/2.3.0/gems/logstash-output-lumberjack-3.1.7/lib/logstash/outputs/lumberjack.rb:86:in connect'", "/appl/elk/logstash-6.6.1/vendor/bundle/jruby/2.3.0/gems/logstash-output-lumberjack-3.1.7/lib/logstash/outputs/lumberjack.rb:49:inregister'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:102:in register'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:46:inregister'", "/appl/elk/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:259:in register_plugin'", "/appl/elk/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:270:inblock in register_plugins'", "org/jruby/RubyArray.java:1734:in each'", "/appl/elk/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:270:inregister_plugins'", "/appl/elk/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:611:in maybe_setup_out_plugins'", "/appl/elk/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:280:instart_workers'", "/appl/elk/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:217:in run'", "/appl/elk/logstash-6.6.1/logstash-core/lib/logstash/pipeline.rb:176:inblock in start'"]}`

any information on that as we can't find a solution ?

Thanks

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.