Logstash unable to listen to Beats Error: event executor terminated


(kave) #1

I attempting to push logs from PacketBeat (Windows) to Logstash to Elastic Cloud. However above error keep looping in /var/log/logstash/logstash-plain.log.

Thanks for assisting

[ERROR][logstash.pipeline ] A plugin had an unrecoverable error. Will restart this plugin.
Plugin: <LogStash::Inputs::Beats port=>5044, host=>"192.168.75.144", id=>"3eab281cd19cfc789322f1908ec4f59590bdc585-1", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_e2e356dd-8c90-4e5a-921b-c1acee060713", enable_metric=>true, charset=>"UTF-8">, ssl=>false, ssl_verify_mode=>"none", include_codec_tag=>true, ssl_handshake_timeout=>10000, congestion_threshold=>5, target_field_for_codec=>"message", tls_min_version=>1, tls_max_version=>1.2, cipher_suites=>["TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384", "TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384", "TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256", "TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256", "TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384", "TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384", "TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256", "TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256"], client_inactivity_timeout=>60>
Error: event executor terminated

Below is my config file in /etc/logstash/conf.d

input {
beats {
port => 5044
host => "192.168.75.144"
}
}
output {
elasticsearch {
hosts => ["https://sanitized:9243"]
user => "elastic"
password => "sanitized"
index => "%{[@metadata][beat]}-%{+YYYY.MM.dd}"
document_type => "%{[@metadata][type]}"
}
}

Below is my PacketBeat Logstash output

#----------------------------- Logstash output --------------------------------
output.logstash:

The Logstash hosts

hosts: ["192.168.75.3:5044"]

Optional SSL. By default is off.

List of root certificates for HTTPS server verifications

#ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"


(Christian Dahlqvist) #2

There seems to be a mismatch here. Try removing the host parameter from the beats input.


(kave) #3

Managed to fix it by removing the host from configuration file. Thanks


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.