Lucene commit failed: checksum failed, while indexing

Hello guys !

I'm faced with this error while indexing:
[2020-10-24T18:18:31,520][WARN ][o.e.i.e.Engine ] [mini-server] [release][0] failed engine [lucene commit failed] org.apache.lucene.index.CorruptIndexException: checksum failed (hardware problem?) : expected=d464d53f actual=a462587c (resource=BufferedChecksumIndexInput(MMapIndexInput(path="/var/lib/elasticsearch/nodes/0/indices/ZyUEzVTkS1S7geQrMnwI7g/0/index/_18_Lucene84_0.doc")))


[2020-10-24T18:18:31,622][INFO ][o.e.c.r.a.AllocationService] [mini-server] Cluster health status changed from [GREEN] to [RED] (reason: [shards failed [[release][0]]]).

Then my index is flagged as RED and the cluster/node is not reachable anymore.

I thought it was an hardware problem as indicated then I changed my only local hard drive to a brand new one fast Kingston.
but I have exactly the same problem.

I have only 1 computer, then 1 cluster, 1 node.
16Gb of Ram
I pushed the heap size from 1Gb to 6Gb: same problem.

I tried to index from bulks of 1000 documents to 1 documents (1 by 1): same problem.

I run with:

  • the latest Elasticsearch version: 7.9.3
  • I'm very large on HDD free space.
  • I pretty sure that did not happened on ES version 6.x

I don't know where to investigate anymore...
I will be thankful for any help.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

Sorry for the delay but I finally found the issue.

I have changed the RAM memory and don't have any errors anymore.
It was really an hardware problem as indicated in the error.