Manticore::ResolutionFailure while sending logs to elasticsearch


(Clash Of Clanss) #1

Hi,

I am trying to send large amount of log files (around 700 files) from logstash to Elasticsearch. But when I start logstash, logs are not sending to the elasticsearch. It throws error something like this,

{:timestamp=>"2018-06-23T10:01:08.602000+0000", :message=>"host..", :class=>"Manticore::ResolutionFailure", :backtrace=>["Logstash/Logstash-900.0-0/vendor/bundle/jruby/1.9/gems/manticore-0.4.4-java/lib/manticore/response.rb:35:in initialize'", "org/jruby/RubyProc.java:271:incall'", "/local/apollo/package/local_1/Linux-2.6c2.5-x86_64/Logstash/Logstash-900.0-0/vendor/bundle/jruby/1.9/gems/manticore-0.4.4-java/lib/manticore/response.rb:70:in call'", "/local/apollo/package/local_1/Linux-2.6c2.5-x86_64/Logstash/Logstash-900.0-0/vendor/bundle/jruby/1.9/gems/manticore-0.4.4-java/lib/manticore/response.rb:245:incall_once'".

{:timestamp=>"2018-06-23T10:01:08.602000+0000", :message=>"Attempted to send a bulk request to Elasticsearch configured at '["http://host:9200/"]', but an error occurred and it failed! Are you sure you can reach elasticsearch from this machine using the configuration provided?", :client_config=>{:hosts=>["http://host:9200/"], :ssl=>nil, :transport_options=>{:socket_timeout=>0, :request_timeout=>0, :proxy=>nil, :ssl=>{}}, :transport_class=>Elasticsearch::Transport::Transport::HTTP::Manticore, :logger=>nil, :tracer=>nil, :reload_connections=>false, :retry_on_failure=>false, :reload_on_failure=>false, :randomize_hosts=>false}, :error_message=>"host", :error_class=>"Manticore::ResolutionFailure",

Thanks in advance.


(Christian Dahlqvist) #2

Sounds like a network or firewall issue. Can you telnet to port 9200 on the Elasticsearch from the host running Logstash?


(Clash Of Clanss) #3

I tried it also but I got the same error message, logs are sending into elasticsearch.

Additional Error message : connect timed out {:class=>"Manticore::ConnectTimeout", :level=>:error}

input {
file {
path => "/logfiles/*"
start_position => "beginning"
sincedb_path => "/dev/null"
}
}

output {
elasticsearch {
hosts => [ "host.ip.address:9200" ]
index => "sample"
}
stdout {
codec => rubydebug
}
}

Thanks.


(Christian Dahlqvist) #4

Were you able to telnet between the nodes?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.