:message=>"Failed to send event to Redis"

Hi All,

We are getting this error message in logstash logs:
{:timestamp=>"2016-02-16T13:31:05.697000+0530", :message=>"Failed to send event to Redis", :event=>#<LogStash::Event:0x19f9088 @accessors=#<LogStash::Util::Accessors:0xc9dee3 @store={"message"=>"dhdieiidjpie", "@version"=>"1", "@timestamp"=>"2016-02-16T06:42:35.738Z", "type"=>"Test_check",

We are using logstash-1.5.3 and redis 3.0.1.

Please Guide.


I just solved the same issue in my server, in my case the problem was in the bind ip address of redis, i have been binding to an ip address of which is a Virtual ip shared between 2 redis server, and after i changed the binding ip to the on redis 1 and on redis 2 and make changes to the host option on logstash shipper, it remained sending data to redis on and the same exception has raised (:message=>"Failed to send event to Redis")
i just fixed the issue by changing the following directive on logstash shipper :slightly_smiling:

host => ["", "", ""]
shuffle_hosts => true

Otherwise, i think it's a cache issue, try to find how to clear it.

the above config has been put in place to figure out the issue only.

Hi Coder,

Thanks for the Suggestion :slightly_smiling:

We have tried that but it didn't work. :pensive:

We have upgraded to logstash-1.5.3 :slightly_smiling:


i'm happy to hear that :slightly_smiling: