:message=>"The error reported is: \n "


(Steve Womack) #1

This isn't very helpful. Where can I go to find out the actual error? I have no idea where to even start with such a vague message.


(Magnus Bäck) #2

It would help if you'd supply more context and your configuration


(Steve Womack) #3

input {
tcp {
port => 5514
type => syslog
}
udp {
port => 5514
type => syslog
}
}


(Steve Womack) #4

output {
rabbitmq {
exchange => 'logstash'
exchange_type => 'topic'
host => 'devamqp.blahblah.com'
user => 'user'
password => 'pass'
}
}


(Steve Womack) #5

assume the hostname, user, and password are correct in my actual configs. This passes configtest. But when the service is started, I just keep getting the vague message I started this thread with


(Magnus Bäck) #6

Okay. No outputs? Which version of Logstash?


(Steve Womack) #7

My output reply should be here, but I'll re-paste: version is logstash 1.5.4

output {
rabbitmq {
exchange => 'logstash'
exchange_type => 'topic'
host => 'devamqp.nothing.com'
user => 'hidden'
password => 'hidden'
}
}


(Magnus Bäck) #8

I'd remove parts of the configuration until it starts working again. I wasn't able to reproduce this problem by just having the inputs.


(Steve Womack) #9

I had to add a vhost setting to my rabbitmq plugin configs. Working now. Still would have been nice to see an actual error message :smiley:


(Magnus Bäck) #10

Indeed. And the vhost you eventually configured was different from the setting's default value ("/")? Please file an issue here: https://github.com/logstash-plugins/logstash-output-rabbitmq/issues/new


(Steve Womack) #11

Done! Thanks


(system) #12