Metricbeat 5.0.0-alpha5 processors range works other than documented


(Martin Kaemmerling) #1

Hello,

I use metricbeat 5.0.0-alpha5 with processors and range.
I tried:

processors:
- drop_event:
    when:
      range:
         lte:
            system.process.cpu.total.pct: 0.0001

which leads to configuration error:

2016/08/11 07:51:14.398256 beat.go:174: INFO Setup Beat: metricbeat; Version: 5.0.0-alpha5
2016/08/11 07:51:14.398327 condition.go:488: ERR Failed to initialize lookup condition: unexpected field pct
2016/08/11 07:51:14.398350 beat.go:284: CRIT Exiting: error initializing processors: unexpected field pct

I tried:

processors:
- drop_event:
    when:
      range:
         system.process.cpu.total.pct.lte: 0.0001

which has no configuration error and leads to:

2016-08-11T09:55:05+02:00 DBG New condition range: map[system.process.cpu.total.pct:<= 0.0001]
..
2016-08-11T12:05:42+02:00 DBG Drop event {

which finally works.
So maybe documentation need to be updated.


(Monica Sarbu) #2

Thank you @kaem2111 for reporting this issue. Indeed it's a bug in the documentation, and we will fix it as soon as possible. For more details about the conditions, you can also check the meta issue, that confirms the format of the range condition.


(Monica Sarbu) #3

Here is the PR that solves the issue: https://github.com/elastic/beats/pull/2241


(system) #4

This topic was automatically closed after 21 days. New replies are no longer allowed.