Metricbeat deamonset no system metrics

Hey guys, I have the deployed metricbeat as a daemonset on a k8s cluster.
I have added the system module in order to monitor worker nodes metrics but it seems that no system metrics are recorded. The configuration is as follows:

[..]
      metricbeat.modules:
        - module: system
          enabled: true
          metricsets:
            - cpu
            - load
            - memory
            - network
            - process
            - process_summary
            - uptime
          period: 10s
          processes: ['.*']
          cpu.metrics:  ["percentages","normalized_percentages"]
          core.metrics: ["percentages"]
          process.include_top_n:
            by_cpu: 5
            by_memory: 5

        - module: kubernetes
          enabled: true
          metricsets:
            - container
            - node
            - pod
            - system
            - volume
          period: 10s
          host: "${NODE_NAME}"
          hosts: ["https://${NODE_NAME}:10250"]
          bearer_token_file: /var/run/secrets/kubernetes.io/serviceaccount/token
          ssl.verification_mode: "none"
          add_metadata: true
            
        - module: kubernetes
          enabled: true
          metricsets:
            - proxy
          hosts: ["localhost:10249"]
          period: 10s
          add_metadata: true

        output.elasticsearch:
          hosts: ["monitoring-poc-es-http:9200"]
          protocol: http
          username: "elastic"
          password: "${ES_PASSWORD}"
          ssl.verification_mode: "none"
          index: "metricbeat-%{[agent.version]}-%{+yyyy.MM.dd}"
          bulk_max_size: 3200
          worker: 4

        setup.kibana:
          host: "http://monitoring-poc-kb-http:5601"
          username: "elastic"
          password: "${ES_PASSWORD}"

        setup.template.name: "metricbeat"
        setup.template.pattern: "metricbeat-*"
        setup.template.overwrite: true
        setup.template.settings:
          index.number_of_shards: 1
          index.number_of_replicas: 1

        processors:
          - add_kubernetes_metadata: ~
[..]

I can see that kubernetes metrics are sent OK. Using the 7.7.1 version of the metricbeat/helm chart.

Any idea what I may be missing?

Thanks

Upgraded to 7.8.0 and also added path to the modules in the config.
Working as designed.