Metricbeat doesn't communicate with Elasticsearch

Hi!

I have installed Metricbeat and I have Security feature installed on my ELK!
After I make all configurations with certificates and modules I get this error:

  "service": {
    "type": "elasticsearch",
    "address": "https://localhost:9200"
  },
  "error": {
    "message": "error determining if connected Elasticsearch node is master: error making http request: Get \"https://localhost:9200/_nodes/_local/nodes\": x509: certificate signed by unknown authority"
  }

and I don't know what to do with it.

Thank you !

Change your hostname from localhost to match the subject in the certificate applied to the server, typically it's the FQDN of the server. You may also need to add ssl configuration options to enable SSL and specify the certificate authority certificate.

1 Like