Metricbeat - resource 'metricbeat-7.10.0' exists, but it is not an alias

Please help me understand this error message.

I have metricbeat with kafka module running on each of my three kafka cluster nodes

this is my metricbeat.yml file

# =========================== Modules configuration ============================
#setup.ilm.overwrite: true
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

# ======================= Elasticsearch template setting =======================

  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

# ---------------------------- Elasticsearch Output ----------------------------
  # Array of hosts to connect to.
  hosts: ["http://*****:9200","http://****:9200","http://*****:9200"]
  username: "****"
  password: "****"

# ================================= Processors =================================

# Configure processors to enhance or manipulate events generated by the beat.

  - add_host_metadata: ~
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

below is my kafka module kafka.yml file. I have one of each on three nodes in my kafka cluster

# Kafka metrics collected using the Kafka protocol
- module: kafka
    - partition
    - consumergroup
  period: 10s
  hosts: ["server1***:9092"]

  client_id: metricbeat
  #retries: 3
  #backoff: 250ms

  # List of Topics to query metadata for. If empty, all topics will be queried.
  #topics: []

# Metrics collected from a Kafka broker using Jolokia
- module: kafka
    - broker
  period: 10s
  hosts: ["server1***:8778"]

when i start up ./metricbeat -e on all three nodes

I see the below error pop up over and over again

2020-12-10T12:26:54.334-0500    ERROR   [publisher_pipeline_output]     pipeline/output.go:154  Failed to connect to backoff(elasticsearch(http://****:9200)): Connection marked as failed because the onConnect callback failed: resource 'metricbeat-7.10.0' exists, but it is not an alias

On the Kibana side i have loaded the dashboard that came with the kafka module but some dashboards have the below error

cannot locate index pattern metricbeat-* error

I tried creating the index pattern manually and still i see this error.

i do see an index called metricbeat-7.10.0 and it has some data in it and continues to get some data.

for example i created a new topic and i dont see it reflect on dashboard.

Does the title error message mean, metricbeat is trying to write to metricbeat-7.10.0 and it is not able to even though it exists?

does the index metricbeat-7.10.0 need aliases set?

I was able to get past the Kibana error - "cannot locate index pattern metricbeat-* error"

I deleted and when I recreated the index pattern, i added a custom pattern with the same name metricbeat-*. Doesnt make sense but saw that in one of the posts and tried it and it worked. not seeing that error anymore.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.