Metricbeat setup failed


(Reza) #1

Hi

I have installed elastic search and metricbeat 6.0 installed.

But when I try to run setup i get following error want to connect to port 443. there is no program listening on port 443, and I have no such a port in my config.

I wonder if you know what I am missing here.

[root@elk6 ~]# metricbeat run -e --setup
2017/12/18 03:51:48.500762 beat.go:436: INFO Home path: [/usr/share/metricbeat] Config path: [/etc/metricbeat] Data path: [/var/lib/metricbeat] Logs path: [/var/log/metricbeat]
2017/12/18 03:51:48.500790 beat.go:463: DBG [beat] Beat metadata path: /var/lib/metricbeat/meta.json
...
2017/12/18 03:52:01.647130 beat.go:276: INFO metricbeat start running.
2017/12/18 03:52:01.647211 reload.go:95: DBG [cfgfile] Checking module configs from: /etc/metricbeat/modules.d/*.yml
2017/12/18 03:52:01.647327 cfgfile.go:143: DBG [cfgfile] Load config from file: /etc/metricbeat/modules.d/elasticsearch.yml
2017/12/18 03:52:01.647504 cfgfile.go:143: DBG [cfgfile] Load config from file: /etc/metricbeat/modules.d/kibana.yml
2017/12/18 03:52:01.647597 cfgfile.go:143: DBG [cfgfile] Load config from file: /etc/metricbeat/modules.d/system.yml
2017/12/18 03:52:01.647799 cfgfile.go:143: DBG [cfgfile] Load config from file: /etc/metricbeat/modules.d/vsphere.yml
2017/12/18 03:52:01.647936 reload.go:109: DBG [cfgfile] Number of module configs found: 6
2017/12/18 03:52:01.647975 processor.go:49: DBG [processors] Processors:
2017/12/18 03:52:01.648066 cfgwarn.go:11: WARN BETA: The elasticsearch node metricset is beta
2017/12/18 03:52:01.648116 cfgwarn.go:11: WARN BETA: The elasticsearch node_stats metricset is beta
2017/12/18 03:52:01.648236 processor.go:49: DBG [processors] Processors:
2017/12/18 03:52:01.648290 cfgwarn.go:11: WARN BETA: The kafka partition metricset is beta
2017/12/18 03:52:01.648356 processor.go:49: DBG [processors] Processors:
2017/12/18 03:52:01.648552 process.go:64: DBG [system.process] process cgroup data collection is enabled, using hostfs=''
2017/12/18 03:52:01.649910 condition.go:97: DBG [processors] New condition regexp: map[system.filesystem.mount_point:\A/(?:sys|cgroup|proc|dev|etc|host|lib)(?:(?-m:$)|/)]
2017/12/18 03:52:01.649935 processor.go:49: DBG [processors] Processors: drop_event, condition=regexp: map[system.filesystem.mount_point:\A/(?:sys|cgroup|proc|dev|etc|host|lib)(?:(?-m:$)|/)]
2017/12/18 03:52:01.650056 processor.go:49: DBG [processors] Processors:
2017/12/18 03:52:01.650136 processor.go:49: DBG [processors] Processors:
2017/12/18 03:52:01.650189 cfgwarn.go:11: WARN BETA: The vsphere datastore metricset is beta
2017/12/18 03:52:01.650873 cfgwarn.go:11: WARN BETA: The vsphere host metricset is beta
2017/12/18 03:52:01.651269 cfgwarn.go:11: WARN BETA: The vsphere virtualmachine metricset is beta
2017/12/18 03:52:01.651784 metrics.go:51: INFO Total non-zero values: beat.info.uptime.ms=13167 beat.memstats.gc_next=4622528 beat.memstats.memory_alloc=3042376 beat.memstats.memory_total=10811640 libbeat.config.module.running=0 libbeat.output.type=elasticsearch libbeat.pipeline.clients=5 libbeat.pipeline.events.active=0
2017/12/18 03:52:01.651805 metrics.go:52: INFO Uptime: 13.167389127s
2017/12/18 03:52:01.651811 beat.go:284: INFO metricbeat stopped.
2017/12/18 03:52:01.651835 beat.go:635: CRIT Exiting: 1 error: 3 errors: Post https://localhost/sdk: dial tcp [::1]:443: getsockopt: connection refused; Post https://localhost/sdk: dial tcp [::1]:443: getsockopt: connection refused; Post https://localhost/sdk: dial tcp [::1]:443: getsockopt: connection refused
Exiting: 1 error: 3 errors: Post https://localhost/sdk: dial tcp [::1]:443: getsockopt: connection refused; Post https://localhost/sdk: dial tcp [::1]:443: getsockopt: connection refused; Post https://localhost/sdk: dial tcp [::1]:443: getsockopt: connection refused


(Mark Walkom) #2

What does your config look like?


(Reza) #3

Here is my config:

[root@elk6 modules.d]# cat /etc/metricbeat/metricbeat.yml
metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
setup.kibana:
  host: "localhost:5601"
output.elasticsearch:
  hosts: ["localhost:9200"]
logging.level: debug
logging.selectors: ["*"]

(ruflin) #4

can you run metricbeat modules list?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.