Metricbeats Configuration Issue: Loading index template in Elasticsearch doesn't work

Hi everyone,

I am trying to change the default Metricbeat index name given to elasticsearch from




However my Elasticsearch index name doesn't change. Down below is my configuration file for metricbeat.yml, I appreciate any suggestions or feedback on what I am doing wrong.

Background Info:

  • Metricbeat version: metricbeat-7.1.1
  • Linux version: 18.10

#========================== Modules configuration ============================

  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: true

  # Period on which files under path should be checked for changes
  reload.period: 5s

#==================== Elasticsearch template setting ==========================

  index.number_of_shards: 1
  index.codec: best_compression
  _source.enabled: false

#-------------------------- Elasticsearch output ------------------------------
  # Array of hosts to connect to.
  hosts: ["***"]

  # Optional protocol and basic auth credentials.
  protocol: "https"
  username: "elastic"
  password: "changeme"
  index: "beatsindex-%{[agent.version]}-%{+yyyy.MM.dd}" "beatsindex"
setup.template.pattern: "beatsindex-*"

#================================ Processors =====================================

# Configure processors to enhance or manipulate events generated by the beat.

  - add_host_metadata: ~
  - add_cloud_metadata: ~

I have same problem.
But I used any magic with parameters setup.template, but it still did not help

I suspect that this is an error version 7.0-7.1
Probably after introduction of ILP+Beats Enroll, new redefinitions of functions were added and this pulled this error.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.