Missing modules.path


#1

hi members,

as already pointed out in that request it seems necessary to enable healthcheck inside the container.

So I tried to set the following commands in the container with these errors.

[root@c1c93cf2f46d metricbeat]# metricbeat modules list
Error in modules manager: modules management requires 'metricbeat.config.modules.path' setting
[root@c1c93cf2f46d metricbeat]# metricbeat modules enable healthcheck
Error in modules manager: modules management requires 'metricbeat.config.modules.path' setting

So when I set such module.path in my metricbeat.yml there will be no more docker metrics transmitted to Elasticsearch.

This is my current metricbeat.yml:

metricbeat.modules:
- module: docker
  metricsets:
    - container
    - cpu
    - diskio
    - healthcheck
    - info
    - memory
    - network
  hosts: ["unix:///var/run/docker.sock"]
  period: 10s
  enable: true

setup.dashboards.enabled: true
setup.kibana:
  host: "10.251.6.190:5601"

output.elasticsearch:
  hosts: ["elasticsearch-coordinating:9200"]

So is there something wrong with the configuration?


(Adrian Serrano) #2

Inside the docker module you have specified enable: true where it should be enabled: true


#3

Ok thanks.
I changed it, but the Errors still exist. He is still complaining to the required 'metricbeat.config.modules.path'.
Does the metricbeat directory need to have a certain structure?


(Güngör Sarıcıoğlu) #4

Hi Invictus,

Did you solve this issue? İf you solved this issue . Could you share solution?

Thanks


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.