Multiline codec - max_age setting not recognized


#1

03:40:16.497 [LogStash::Runner] ERROR logstash.codecs.multiline - Unknown setting 'max_age' for multiline

CentOS release 6.8 (Final)
logstash 5.0.0


(Magnus B├Ąck) #2

Yes. As documented, the multiline codec doesn't have a max_age option. Perhaps auto_flush_interval solves the same problem for you?


#3

Thank you for your reply.

For some reason I thought max_age was documented under both filter plugin and codec. Checking again, that isn't the case.

auto_flush_interval does indeed solve the problem. Merci!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.