Multiple document- types in filebeat


(John) #1

Hi All

I need to set the multiple document_type for each log path, blow is the configuration that i used .

After that filebeat only send lastly defined log files to the server ( document_type with cucum-cdr) , not the document_type with syslog .

Can you guys please advice me how to fix this issue , Need to send both log files to the server with different document types

filebeat:
prospectors:
-

  paths:
    - "/home/syslog/filebeat/redware/*.log"
  document_type: syslog

 paths:
    - "/home/voip/cdr_StandAloneCluster_01_2016*"
 document_type: cucm-cdr

(Magnus B├Ąck) #2

The formatting of your configuration is mangled so I'm not sure exactly what it looks like (always post Filebeat configuration formatted as code), but it seems to be this:

filebeat:
  prospectors:
    -
      paths:
         - "/home/syslog/filebeat/redware/*.log"
      document_type: syslog

      paths:
        - "/home/voip/cdr_StandAloneCluster_01_2016*"
      document_type: cucm-cdr

If that's the case then you're missing a "-" before the second "paths" declaration. See the example at https://www.elastic.co/guide/en/beats/filebeat/current/configuration-filebeat-options.html.


Filebeat to logstash multiple indexs
(John) #3

Thanks


(system) #4