Multiple Pipeline now working


(Mancharagopan) #1

Hi,

I am trying to configure logstash with multiple pipelines. Beats and Syslog but only Beats pipeline is working.

[2018-10-24T10:55:13,949][INFO ][logstash.runner          ] Starting Logstash {"logstash.version"=>"6.4.2"}
[2018-10-24T10:55:13,977][DEBUG][logstash.agent           ] Starting agent
[2018-10-24T10:55:14,027][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/etc/logstash/pipelines.yml"}
[2018-10-24T10:55:14,136][DEBUG][logstash.config.source.local.configpathloader] Skipping the following files while reading config since they don't match the specified glob pattern {:files=>[]}
[2018-10-24T10:55:14,146][DEBUG][logstash.config.source.local.configpathloader] Reading config file {:config_file=>"/etc/logstash/conf.d/filter.conf"}
[2018-10-24T10:55:14,174][DEBUG][logstash.config.source.local.configpathloader] Skipping the following files while reading config since they don't match the specified glob pattern {:files=>[]}
[2018-10-24T10:55:14,175][DEBUG][logstash.config.source.local.configpathloader] Reading config file {:config_file=>"/etc/logstash/conf/udpinput.conf"}
[2018-10-24T10:55:14,231][DEBUG][logstash.agent           ] Converging pipelines state {:actions_count=>2}
[2018-10-24T10:55:14,243][DEBUG][logstash.agent           ] Executing action {:action=>LogStash::PipelineAction::Create/pipeline_id:syslog}
[2018-10-24T10:55:14,242][DEBUG][logstash.agent           ] Executing action {:action=>LogStash::PipelineAction::Create/pipeline_id:beats}
[2018-10-24T10:55:15,074][ERROR][logstash.agent           ] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:syslog, :exception=>"LogStash::ConfigurationError", :message=>"Expected one of #, if, \", ', } at line 16, column 1 (byte 247) after output {\n   elasticsearch {\n    hosts => [\"172.20.11.19:9200\"]\n    sniffing => true\n    manage_template => true\n    index => \"%{[@metadata]}-%{+YYYY.MM.dd}\"\n    document_type => \"%{[@metadata][type]}\"\n\n}\n", :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:49:in `compile_graph'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2486:in `map'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:149:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:22:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:90:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:38:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:309:in `block in converge_state'"]}
[2018-10-24T10:55:17,658][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"beats", :type=>"input", :class=>LogStash::Inputs::Beats}
[2018-10-24T10:55:17,859][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"plain", :type=>"codec", :class=>LogStash::Codecs::Plain}

My pipeline configuration is,

- pipeline.id: beats
  path.config: "/etc/logstash/conf.d/filter.conf"
- pipeline.id: syslog
  path.config: "/etc/logstash/conf/udpinput.conf"

Any idea what's wrong?


(Mancharagopan) #2

Sorry! I solved it.
i didn't close output {} in the .conf file.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.