Multiple pipelines not working while using YAML hierarchical form

  • Version: 7.4.0

  • Operating System: Red Hat Enterprise Linux Server release 7.6 (Maipo)

  • Steps to Reproduce: Use hierarchical yaml form in multiple pipelines definition.

When I create a pipelines.yml file like this :

- path:
    config: "/applis/logstash/pipelines/instance-01/zabbix/zabbix.conf"
    id: "zabbix"
    workers: 1

I have the following error :
[2019-10-28T14:53:18,939][ERROR][logstash.config.sourceloader] Could not fetch all the sources {:exception=>ArgumentError, :message=>"Only pipeline related settings are expected. Received \"path\". Allowed settings: [\"config.debug\", \"config.support_escapes\", \"config.reload.automatic\", \"config.reload.interval\", \"config.string\", \"dead_letter_queue.enable\", \"dead_letter_queue.max_bytes\", \"metric.collect\", \"pipeline.java_execution\", \"pipeline.plugin_classloaders\", \"path.config\", \"path.dead_letter_queue\", \"path.queue\", \"pipeline.batch.delay\", \"pipeline.batch.size\", \"\", \"pipeline.reloadable\", \"pipeline.system\", \"pipeline.workers\", \"queue.checkpoint.acks\", \"queue.checkpoint.interval\", \"queue.checkpoint.writes\", \"queue.checkpoint.retry\", \"queue.drain\", \"queue.max_bytes\", \"queue.max_events\", \"queue.page_capacity\", \"queue.type\"]"

But if I change for flat syntax:

- path.config: "/applis/logstash/pipelines/instance-01/zabbix/zabbix.conf" "zabbix"
  pipeline.workers: 1

Pipeline is working.

I found this issue when I tried to manage this file with an ansible template that use to_nice_yaml filter.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.