New logstash 5.x does not support `-server` flag for JVM?


(Draven Johnson) #1

We used to use -server flag to get better performance to logstash JVM server. Seem like this option no longer valid?

We tried to set -server flag in jvm.option or startup.option, or both. None of those setting triggered when logstash start


(Aaron Mildenstein) #2

When you say you tried it in the jvm.options file, it depends on how/where you did this.

Did you install via RPM or DEB? Edit /etc/logstash/jvm.options
If you installed via tarball or zip package to somewhere else, it will be in $LS_HOME/config/jvm.options

It may be moot, though. When I just run java at the command-line, I see this:

    -server	  to select the "server" VM
                  The default VM is server,
                  because you are running on a server-class machine.

In other words, it's -server by default, so adding it may be superfluous, or simply not shown.


(Draven Johnson) #3

Yes, we do try edit /etc/logstash/jvm.options and everything else works (such as HEAP size)

even it's default, but we still feeling to add that flag -server to jvm.options but seem like adding it to the file won't work.

Do i need some extra action to make it works?


(Aaron Mildenstein) #4

Everything else read in the jvm.options file is added. I get the idea that it's ignored since it's the default.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.