No ouput using logstash file plugin

I'm using Windows 10.
Logstash 7.2.0

I just want to see the output of filter in console window..

My config c.conf:

input {
      file {
        path => "D:\Elastic\logstash-7.2.0\test\theLogFile"
        start_position => "beginning"
        mode => "read"
    output {
        stdout { codec => rubydebug }

My log file theLogFile:

2019-01-09 09:01:05,333 ERROR-Log Message
2019-01-10 09:01:05,333 WARNING-Log Message

Then I run the logstash:
.\bin\logstash -f test\c.conf --config.reload.automatic

The output:

Thread.exclusive is deprecated, use Thread::Mutex
Sending Logstash logs to D:/Elastic/logstash-7.2.0/logs which is now configured via
[2019-07-10T10:07:28,637][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-07-10T10:07:28,666][INFO ][logstash.runner          ] Starting Logstash {"logstash.version"=>"7.2.0"}
[2019-07-10T10:07:35,759][WARN ][org.logstash.instrument.metrics.gauge.LazyDelegatingGauge] A gauge metric of an unknown type (org.jruby.RubyArray) has been create for key: cluster_uuids. This may result in invalid serialization.  It is recommended to log an issue to the responsible developer/development team.
[2019-07-10T10:07:35,766][INFO ][logstash.javapipeline    ] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>8, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>1000, :thread=>"#<Thread:0x5e611e6b run>"}
[2019-07-10T10:07:36,792][INFO ][logstash.inputs.file     ] No sincedb_path set, generating one based on the "path" setting {:sincedb_path=>"D:/Elastic/logstash-7.2.0/data/plugins/inputs/file/.sincedb_4c88b325039e0801e1b541e2cf388ac7", :path=>["D:\\Elastic\\logstash-7.2.0\\test\\theLogFile"]}
[2019-07-10T10:07:36,840][INFO ][logstash.javapipeline    ] Pipeline started {""=>"main"}
[2019-07-10T10:07:36,930][INFO ][filewatch.observingread  ] START, creating Discoverer, Watch with file and sincedb collections
[2019-07-10T10:07:36,938][INFO ][logstash.agent           ] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>[]}
[2019-07-10T10:07:37,310][INFO ][logstash.agent           ] Successfully started Logstash API endpoint {:port=>9600}

I also tried to edit the file but No Ouput either.
Please help me.

Use forward slash in filenames in the path option of a file filter.

I just add JVM_HOME env variable and it works. Not sure what is the problem

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.