No output - (no matches ?) with my config-file

Hi everyone.

So, I'm a little bit new at the elk-stack, and I’m having an issue with further experiment with the tools. I'm using a linux machine.
First of all, here's my config-file :

input {
file {
type => "openerp"
path => "/home/jvc/Documents/log/openerp-cron.log.2014-11-20.txt"
start_position => "beginning"
codec => multiline{
pattern => "^%{TIMESTAMP_ISO8601} "
negate => true
what => previous
if [type]=="openerp"{
match => ["timestamp","yyyy-MM-dd HH:mm:ss,SSS"]
patterns_dir => "./patterns"
match => { "message" => "%{ODOOLOG}" }
path => "/home/jvc/Bureau/testretour.txt"

I have some patterns too :

REQUEST %{IPORHOST:client} %{USER:ident} %{USER:auth} [%{REQUESTTIMESTAMP:request_timestamp}] "%{WORD:request_type} %{URIPATHPARAM:request} HTTP/%{NUMBER:httpversion}" %{NUMBER:response} -
ODOOLOG %{TIMESTAMP_ISO8601:timestamp} %{POSINT:pid} %{LOGLEVEL:level} (?:%{USERNAME:user}|?) %{PROG:module}: (?:%{REQUEST}|%{ODOOMISC:misc})

Some examples of the logs :

2014-11-21 08:00:16,715 17798 DEBUG noe cron.object.execute('noe', 1, '*', u'crossovered.budget.lines', u'_compute_blank')
2014-11-21 08:00:17,172 17798 WARNING noe openerp.osv.orm.browse_record.noe_utils.synchro_date: Field 'conform' does not exist in object 'browse_record(noe_utils.synchro_date, 13)'
2014-11-21 08:00:17,172 17798 ERROR noe openerp.sql_db: Programming error: can't adapt type 'browse_record', in query SELECT id
FROM crossovered_budget_lines
WHERE is_blank='t'
AND general_budget_id in %s
AND date_from <= %s AND date_to >= %s
2014-11-21 08:00:17,173 17798 ERROR noe Call of self.pool.get('crossovered.budget.lines')._compute_blank(cr, uid, *()) failed in Job 10

I'm having trouble with this config. For some reason that I can't find, this produces nothing.
What I have tried - done :
-First of all, I tested my grok, and multiline pattern in some grok debugger I have find on the web. All of them matches my logs.
-Before using the codec for multiline, i used the multiline filter. This one worked, but seems to be deprecated. So it's not a solution.
-I know that logstash keep in mind what he had read or not with the "sincedb" files : I delete these before every test, but you know what happens.
-I tried to run logstash with the -verbose, but nothing wrong is displayed.
-I don't really know if I must write the ".txt" at the end of my paths. But anyway, none of them works.

Have I missed something ? Thank you in advance for helping hands.

So, with more test I succeeded. I copied the content of one of my logs file and pasted it in another file : It works.

But, there is now another question : if deleting the "sincedb" file doesn't work, how can i "empty" the cache of logstash ?

Deleting the sincedb file(s) will work, but you have to shutdown Logstash before removing them. Logstash's verbose logs (i.e. start with --verbose) will tell you everything you need to know about which files are tracked, which sincedb files there are, the current position in the input files, and so on.