Not able to see the out when i run logstash


(Naga Kunchala) #1

when i run logstash withe ./logstash -f /etc/logstash/conf.d/logstash-filter.conf.

not geeting any output and see the below error.

[root@localhost bin]# ./logstash -f /etc/logstash/conf.d/logstash-filter.conf
OpenJDK 64-Bit Server VM warning: If the number of processors is expected to increase from one, then you should configure the number of parallel GC threads appropriately using -XX:ParallelGCThreads=N
WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console
[INFO ] 2018-05-30 22:01:45.942 [main] scaffold - Initializing module {:module_name=>"fb_apache", :directory=>"/usr/share/logstash/modules/fb_apache/configuration"}
[INFO ] 2018-05-30 22:01:45.950 [main] scaffold - Initializing module {:module_name=>"netflow", :directory=>"/usr/share/logstash/modules/netflow/configuration"}
[WARN ] 2018-05-30 22:01:46.667 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified
[INFO ] 2018-05-30 22:01:46.951 [LogStash::Runner] runner - Starting Logstash {"logstash.version"=>"6.2.4"}
[INFO ] 2018-05-30 22:01:47.242 [Api Webserver] agent - Successfully started Logstash API endpoint {:port=>9601}
[INFO ] 2018-05-30 22:01:48.250 [Ruby-0-Thread-1: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] pipeline - Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>1, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50}
[INFO ] 2018-05-30 22:01:48.763 [Ruby-0-Thread-1: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] pipeline - Pipeline started successfully {:pipeline_id=>"main", :thread=>"#<Thread:0x11dc8c05@/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:247 run>"}
[INFO ] 2018-05-30 22:01:48.776 [Ruby-0-Thread-1: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] agent - Pipelines running {:count=>1, :pipelines=>["main"]}


(Naga Kunchala) #2

can you help me on this


(Magnus Bäck) #3

And what's in logstash-filter.conf?


(Naga Kunchala) #4

input {
file {
path => "/home/kunchala/log.txt"
start_position => "beginning"
}
}
output {
stdout {}
file {
path => "/home/kunchala/logstash.txt"
}
}


(Magnus Bäck) #5

I'm guessing Logstash thinks it already has processed the file. You can use the sincedb_path option to the file input to reset Logstash's opinion of the current position in the file. Please consult the file input documentation and countless previous posts on this topic.


(Naga Kunchala) #6

i am new to logstash, can you please provide one example how to use sincedb_path option to the file input to reset Logstash's opinion of the current position in the file


(Naga Kunchala) #7

can you please help me still i am facing same issue


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.