Only default time filter field name appears


(Icg) #1

I run this Logstash code in Elasticstack 5.0.0 and when I open Kibana, I can see two Time Filter field names: @timestam and CapturedOn. However if I run the same code in Elasticstack 5.5.0, then I see only one Time Filter field name: @timestamp. What is wrong here?

input {
    file {
        path => ["/usr/test/000002_0"]
        start_position => "beginning"
    }
}

filter {
    csv {
      separator => ","
      columns => ["Id","AnotherId","CapturedOn"]
    }
    mutate {
	add_field => {
		"CapturedOn" => "%{CapturedOn}"
    	}
    }
    date
    {
	match => [ "CapturedOn", "YYYY-MM-dd HH:mm:ss.SSS"]
	target => "CapturedOn"
    }
}

output {
    stdout { codec => rubydebug }
    elasticsearch {
        action => "index"
        hosts => ["127.0.0.1:9200"]
        index => "test"
        document_type => "registry"
        document_id => "%{Id}"
        workers => 1
    }
}

#2

I'm seeing the same thing.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.