Path to Logs not respected


I've upgraded one metricbeat installation to 7.7. Since the upgrade, the logs are written in /var/log/messages and not respecting the -path.logs setting.

From the former releases I have customized systemd to this setting:

The process looks like this:
/usr/share/metricbeat/bin/metricbeat -environment systemd -c /etc/metricbeat/metricbeat.yml -path.home /usr/share/metricbeat -path.config /etc/metricbeat /var/lib/metricbeat -path.logs /var/log/metricbeat

Is a setting wrong, or is this a bug in 7.7.0 ?

Best regards,


Have you tried adjusting the settings via the metricbeat config here:

Also can you copy and paste the entire systemd unit config that you modified?


my problem was also described here, seems to be a change that was introduced with 7.7.0.

I've changed the metricbeat.yml to adjust the setting and it works.

Thanks for your advice.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.