Pipeline aborted due to error , Translation is missing

input {
file {
path => "C:/Users/sagar.dhakate/Sagar_FTTC.csv"
start_position => "beginning"
sincedb_path => "NULL"
ignore_older => 0
}

	}

filter {
csv {
separator => ","
columns => ["Product", "Date", "Total Order", "Completed Order", "RFT Percent"]
}
mutate {convert => ["Product" , "string"]}
mutate {convert => ["Total Order" , "integer"]}
mutate {convert => ["Completed Order" , "integer"]}
mutate {convert => ["RFT Percent" , "float"]}

	date
	 { 
	  match => ["Date", "yyyyMMdd hh:mm:ss"]
	  }
	}

output {

stdout { codec => json_lines }
elasticsearch{
	hosts => ["VIMPHYT01-22:9200"]
	index => "fttc_status"
	}

}

Blockquote

2020-02-19T21:35:49,862][ERROR][logstash.javapipeline ][main] Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<LogStash::ConfigurationError: translation missing: en.logstash.agent.configuration.invalid_plugin_register>, :backtrace=>["C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/vendor/bundle/jruby/2.5.0/gems/logstash-filter-mutate-3.5.0/lib/logstash/filters/mutate.rb:222:in block in register', "org/jruby/RubyHash.java:1417:in each'", "C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/vendor/bundle/jruby/2.5.0/gems/logstash-filter-mutate-3.5.0/lib/logstash/filters/mutate.rb:220:in register'", "org/logstash/config/ir/compiler/AbstractFilterDelegatorExt.java:56:in register'", "C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/logstash-core/lib/logstash/java_pipeline.rb:199:in block in register_plugins'", "org/jruby/RubyArray.java:1800:in each'", "C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/logstash-core/lib/logstash/java_pipeline.rb:198:in register_plugins'", "C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/logstash-core/lib/logstash/java_pipeline.rb:475:in maybe_setup_out_plugins'", "C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/logstash-core/lib/logstash/java_pipeline.rb:211:in start_workers'", "C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/logstash-core/lib/logstash/java_pipeline.rb:153:in run'", "C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/logstash-core/lib/logstash/java_pipeline.rb:108:in `block in start'"], "pipeline.sources"=>["C:/Users/sagar.dhakate/Software/ElasticStack/logstash-7.5.0/logstash-7.5.0/bin/fttc_csv.conf"], :thread=>"#<Thread:0x1edebebc run>"}
[2020-02-19T21:35:49,909][ERROR][logstash.agent ] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create, action_result: false", :backtrace=>nil}
[2020-02-19T21:35:49,955][INFO ][logstash.outputs.elasticsearch][main] Attempting to install template {:manage_template=>{"index_patterns"=>"logstash-", "version"=>60001, "settings"=>{"index.refresh_interval"=>"5s", "number_of_shards"=>1, "index.lifecycle.name"=>"logstash-policy", "index.lifecycle.rollover_alias"=>"logstash"}, "mappings"=>{"dynamic_templates"=>[{"message_field"=>{"path_match"=>"message", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false}}}, {"string_fields"=>{"match"=>"", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false, "fields"=>{"keyword"=>{"type"=>"keyword", "ignore_above"=>256}}}}}], "properties"=>{"@timestamp"=>{"type"=>"date"}, "@version"=>{"type"=>"keyword"}, "geoip"=>{"dynamic"=>true, "properties"=>{"ip"=>{"type"=>"ip"}, "location"=>{"type"=>"geo_point"}, "latitude"=>{"type"=>"half_float"}, "longitude"=>{"type"=>"half_float"}}}}}}}
[2020-02-19T21:35:50,393][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2020-02-19T21:35:55,143][INFO ][logstash.runner ] Logstash shut down.

Please help me to resolve this issue.

Not sure why you are getting that exception, but if you do not want the file input to persist the sincedb to disk when it stops you should use "NUL" rather than "NULL".

Also, do not use 'ignore_older => 0'. In filebeat that is used to turn off filtering by age. For a file input it means to ignore any files more than zero seconds old, which means it ignores all files.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.