Pipelines.yml pipeline to pipeline address unavailable error again!

Hi. I don't understand why my multipiplines don't work while it should as I've created config files by an example. I've tried to restart Logstash as it was using a single-file pipeline (using -f flag). Logstash is a container and its version is 7.5.1. What's wrong with any of the files? Here's pipelines.yml:

 - pipeline.id: main
   config.string: |
    input {
      beats {
         port => 5000
         ssl => true
         ssl_certificate => "/logstash.crt"
         ssl_key => "/logstash.key"

output {
  if [container][name] =~ 'redis' {
    pipeline {
      send_to => redis
- pipeline.id: redis
  queue.type: persisted
  pipeline.workers: 1
  path.config: "/usr/share/logstash/pipeline/redis.conf"


input {
 pipeline {
  address => redis

output {
    elasticsearch {
            hosts => "elasticsearch:9200"
            user => "user"
            password => "password"
            ilm_enabled => true
            template_overwrite => true
            ilm_rollover_alias => "redis"
            ilm_policy => "generic"
            index => "redis"
    stdout { codec => json}

Errors I get:

  Attempted to send event to 'redis' but that address was unavailable. Maybe the destination pipeline is down or stopping? Will Retry.
  [logstash.config.source.local.configpathloader] No config files found in path {:path=>"/usr/share/logstash/pipeline/redis.conf"}


Have you tried placing the redis.conf in another directory? Maybe LogStash has not anough privileges to read the file?

Best regards

It has such permissions: it can read the redis.conf and any other files in the same directory.

So the question is: why Logstash can't access the redis virtual address? We have the same setup on another ELK and there it works fine.

Turns out I was using yml files while it should conf files. My bad.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.