Please Help, I can't get logstash 6.1.1 to listen on port on windows


#1

I believe I have followed all the setup procedures/configurations mentioned but no matter what I try there is nothing listening on the specified port (5044). I have tried to follow everything I can find in this forum, but all of the suggestions I can find are for Linux and suggest modifying files in locations that do not exist on windows. Please help me configure my instance of logstash to listen on port 5044. here is the relevant contents of the various config files:

logstash.yml

------------ Metrics Settings --------------

Bind address for the metrics REST endpoint

http.host: "127.0.0.1"

http.host: "10.100.96.154"

Bind port for the metrics REST endpoint, this option also accept a range

(9600-9700) and logstash will pick up the first available ports.

http.port: 9600-9700

pipelines.yml

Example of two pipelines:

- pipeline.id: test

pipeline.workers: 1

pipeline.batch.size: 1

config.string: "input { generator {} } filter { sleep { time => 1 } } output { stdout { codec => dots } }"

- pipeline.id: another_test

queue.type: persisted

path.config: "/tmp/logstash/*.config"

  • pipeline.id: apache_logs
    queue.type: persisted
    path.config: "C:\ELK\logstash-6.1.1\config*.conf"

apache-pipeline.conf

The # character at the beginning of a line indicates a comment. Use

comments to describe your configuration.

input {
beats {
port => "5044"
}
}

The filter part of this file is commented out to indicate that it is

optional.

#filter {

grok {

match => { "message" => "%{COMBINEDAPACHELOG}"}

}

geoip {

source => "clientip"

}

#}
output {
elasticsearch {
hosts => [ sv-picsch3-prd:9200 ]
}
}

So what am I missing?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.