Positive lookahead not working

hi guys,

i want to return or get output 40:123 , whereas input is 40$:123 ---- want to use lookahead , but it always return in output if i use below...any idea, need to used lookahead $ is must in named capture.

input string


What filter are you using? Why do you want to use lookahead? If you want to remove the $ then why not just use mutate+gsub?

i have input like this


i need to check if key is followed by $ but i don't want to return it...i know we can use other options why its not working using lookahead ...

You have not given any indication of your filter configuration, so it is impossible to help you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.