Prevent pop up with the error "To create custom links, you must be subscribed to an Elastic Gold license or above. With it, you'll have the ability to create custom links to improve your workflow when analyzing your services" appears in kibana apm service

After configure APM in some agents, when i go to page

APM -> Services -> foo -> Transactions -> PUT Media/UpdateMedia {mediaID/sourceID/version}

to see my headers in request, i got the error 403 with on get in this url:
https://kibana.example.com/api/apm/settings/custom_links?service.name=foo&transaction.name=PUT%20Media%2FUpdateMedia%20{mediaID%2FsourceID%2Fversion}&transaction.type=request

when I go to link to see what i got, i got this JSON:
{"statusCode":403,"error":"Forbidden","message":"To create custom links, you must be subscribed to an Elastic Gold license or above. With it, you'll have the ability to create custom links to improve your workflow when analyzing your services."}

I using the open source version, and don't want subscribe to elatic gold to stop see this popup.

Can you help me to find how to prevent this pop up appears?

You are probably using the Basic distribution, as that includes APM.

I'm not sure how to disable that though, hopefully an APM dev can chime in (I've moved this to the APM category too!).

1 Like

Yes, you're right. I'm using the Basic distribution.
Many thank's for your attention

1 Like

@zbioe this is going to be fixed on this PR https://github.com/elastic/kibana/pull/83836

1 Like

Awesome Caue! Many thank's for your help!! Thank's for Mark and the rest of the team