Problem with filebeat upgrade

I was using filebeat 7.10 and all ok, now was trying upgrading to 7.15 and I found two problem

I have tried to download the version of the link

curl -L -O

And I have only made the changes:

  • Namespace from kube-system to logging, which is the one we use,
  • the configuration of the daemonset with our variables and passwords and
  • the configuration of the filebeat that I attach.

If I run it, it creates me in a cluster with 6 nodes (3 default GCP + 3 preemptible nodes), it is only deployed in the default nodes, (first thing different from the previous version that was installed in all)

And if I look at the logs (default nodes) I don't see that it shows anything, and the pods are ready.

NAME                                                  STATUS   ROLES    AGE     VERSION
gke-plugins-stage-default-node-pool-3ea1dedc-h9er     Ready    <none>   269d    v1.17.14-gke.1600
gke-plugins-stage-default-node-pool-769096cb-xqnz     Ready    <none>   269d    v1.17.14-gke.1600
gke-plugins-stage-default-node-pool-95883f48-wzgm     Ready    <none>   128d    v1.17.14-gke.1600
gke-plugins-stage-preemptible-node-po-21a714f2-2sxd   Ready    <none>   107m    v1.17.14-gke.1600
gke-plugins-stage-preemptible-node-po-21a714f2-9x6p   Ready    <none>   5m18s   v1.17.14-gke.1600
gke-plugins-stage-preemptible-node-po-61ca3fa6-lkzq   Ready    <none>   43h     v1.17.14-gke.1600
gke-plugins-stage-preemptible-node-po-c3aa2beb-rp41   Ready    <none>   22h     v1.17.14-gke.1600
NAME             READY   STATUS    RESTARTS   AGE   IP            NODE                                                NOMINATED NODE   READINESS GATES
filebeat-kkbrx   1/1     Running   0          20s   gke-plugins-stage-default-node-pool-95883f48-wzgm   <none>           <none>
filebeat-m5j55   1/1     Running   0          20s   gke-plugins-stage-default-node-pool-769096cb-xqnz   <none>           <none>
filebeat-zcqdm   1/1     Running   0          20s   gke-plugins-stage-default-node-pool-3ea1dedc-h9er   <none>           <none>

kubectl logs -f filebeat-kkbrx -n logging

And in ElasticCloud nothing comes either. So we have two problems, one that the daemonset is not installed in all our nodes (default and preemptibles) and another is that it does not show anything in the logs.

I don't know to debug/solve this problem, could anyone give a hand?

Thank you very much

Any suggestion I can try? please I really appreciate it

How can debug filebeat? I've achieve install filebeat agent but when I see the logs in the pod all are empty, I see the index create too in ElasticCloud with mapping and so on, but nothing inside.

I would like can debug the filebeat pods, but I don't know how to do it.

Any suggestion? I'm using the lastest version 7.15

Thank you very much

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.