Problem with filebeat.yml


(Saketh Chandra Kolisetty) #1

hi there,
I am trying to send logs from filebeat to logstash.As stated in the yml file i have commented the elasticsearch output and uncommented the one for logstash but i happen to get this error:

PS C:\Program Files\Filebeat> ./filebeat -e -c filebeat.yml -d "elasticsearch"
filebeat2018/06/01 06:01:16.905020 beat.go:339: CRIT Exiting: error loading config file: yaml: line 92: did not find expected key
Exiting: error loading config file: yaml: line 92: did not find expected key
PS C:\Program Files\Filebeat>


(Noémi Ványi) #2

Could you please share your config as a text formatted using </>? It makes it easier for us to check your config.

My guess based on the screenshot is that the indentation of output.logstash is not correct. But it's very hard to tell without seeing the full configuration idendented as it's done in your config file.


(Saketh Chandra Kolisetty) #3
----------------------------- Logstash output --------------------------------
 output.logstash:
  # The Logstash hosts
 hosts: ["localhost:5044"]

hi,
is this fine ?


(Noémi Ványi) #4

I get a different error for this snippet you provided:

 Exiting: error initializing publisher: No outputs are defined. Please define one under the output section.

This could be eliminated with the following:

output.logstash:
  # The Logstash hosts
 hosts: ["localhost:5044"]

However, I still need to see your full configuration. If it contains sensitive data, just change it to x or something else.


(Saketh Chandra Kolisetty) #5

hi Noemi,
including </> on everyline would take lot of time.is there any other way i could send you the config file? probably mail you ?


(Saketh Chandra Kolisetty) #6

kvch https://discuss.elastic.co/u/kvch Noémi Ványi
https://discuss.elastic.co/u/kvch Elastic Team Member
June 1

I get a different error for this snippet you provided:

Exiting: error initializing publisher: No outputs are defined. Please define one under the output section.

This could be eliminated with the following:

output.logstash:

The Logstash hosts

hosts: ["localhost:5044"]

However, I still need to see your full configuration. If it contains
sensitive data, just change it to x or something else.

Visit Topic
https://discuss.elastic.co/t/problem-with-filebeat-yml/134144/4 or
reply to this email to respond.

In Reply To
Saketh_Chandra_Kolis https://discuss.elastic.co/u/saketh_chandra_kolis Saketh
Chandra Kolisetty https://discuss.elastic.co/u/saketh_chandra_kolis
June 1
----------------------------- Logstash output
-------------------------------- output.logstash: # The Logstash hosts
hosts: ["localhost:5044"] hi, is this fine ?

Visit Topic
https://discuss.elastic.co/t/problem-with-filebeat-yml/134144/4 or
reply to this email to respond.

To unsubscribe from these emails, click here
https://discuss.elastic.co/email/unsubscribe/9e21774f538260b89703c8a693c3f75b9e567cd0290a57e0f58e2aaa39481721
.


(Noémi Ványi) #7

I am not sure I understand your problem. You don't need to do it for every line. You can highlight everything and click on </>. If it's not working for you, you could paste your config to Pastebin: https://pastebin.com/


(Saketh Chandra Kolisetty) #8
###################### Filebeat Configuration Example #########################

# This file is an example configuration file highlighting only the most common
# options. The filebeat.full.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/filebeat/index.html

#=========================== Filebeat prospectors =============================

filebeat.prospectors:

# Each - is a prospector. Most options can be set at the prospector level, so
# you can use different prospectors for various configurations.
# Below are the prospector specific configurations.

- input_type: log

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
    - C:\Users\Mahe\Desktop\intership\apache.log
    
    #- c:\programdata\elasticsearch\logs\*

  # Exclude lines. A list of regular expressions to match. It drops the lines that are
  # matching any regular expression from the list.
  #exclude_lines: ["^DBG"]

  # Include lines. A list of regular expressions to match. It exports the lines that are
  # matching any regular expression from the list.
  #include_lines: ["^ERR", "^WARN"]

  # Exclude files. A list of regular expressions to match. Filebeat drops the files that
  # are matching any regular expression from the list. By default, no files are dropped.
  #exclude_files: [".gz$"]

  # Optional additional fields. These field can be freely picked
  # to add additional information to the crawled log files for filtering
  #fields:
  #  level: debug
  #  review: 1

  ### Multiline options

  # Mutiline can be used for log messages spanning multiple lines. This is common
  # for Java Stack Traces or C-Line Continuation

  # The regexp Pattern that has to be matched. The example pattern matches all lines starting with [
  #multiline.pattern: ^\[

  # Defines if the pattern set under pattern should be negated or not. Default is false.
  #multiline.negate: false

  # Match can be set to "after" or "before". It is used to define if lines should be append to a pattern
  # that was (not) matched before or after or as long as a pattern is not matched based on negate.
  # Note: After is the equivalent to previous and before is the equivalent to to next in Logstash
  #multiline.match: after


#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
#  env: staging

#================================ Outputs =====================================

# Configure what outputs to use when sending the data collected by the beat.
# Multiple outputs may be used.

#-------------------------- Elasticsearch output ------------------------------
#output.elasticsearch:
  # Array of hosts to connect to.
 # hosts: ["localhost:9200"]
 

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

#----------------------------- Logstash output --------------------------------
output.logstash:
  # The Logstash hosts
 hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: critical, error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

(Noémi Ványi) #9

What's the version of Filebeat you are running?


(Harsh Bajaj) #10

Hi,

It looks like the problem is with indentation in your file with SSL lines.

Your Config:
# Optional SSL. By default is off.
# List of root certificates for HTTPS server verifications
#ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]
# Certificate for SSL client authentication
#ssl.certificate: "/etc/pki/client/cert.pem"
# Client Certificate Key
#ssl.key: "/etc/pki/client/cert.key"

Please add one more space between # and SSL in you all line like below and restart the service.

TRY this:
# Optional SSL. By default is off.
# List of root certificates for HTTPS server verifications
# ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]
# Certificate for SSL client authentication
# ssl.certificate: "/etc/pki/client/cert.pem"
# Client Certificate Key
# ssl.key: "/etc/pki/client/cert.key"

Please do let me know if you are still getting this error.

Regards,


(Saketh Chandra Kolisetty) #11

hi Harsh,
It works now !!!! how did u figure it out ?


(Saketh Chandra Kolisetty) #12

hi,
i am using 5.4.1 .


(Harsh Bajaj) #13

Hi,

I just copy your config file in my environment and reproduce this issue and found that there is some indentation problem.

Below is the link of filebeat documentation about indentations.
https://www.elastic.co/guide/en/beats/filebeat/current/yaml-tips.html

Regards,


(system) #14

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.