Problem with logstash:name error


(belhadj) #1

Need help SOS!
i have been using Logstash for 2 months now .2days ago out of nowhere a problem appeared that i can't find its origin:

logstash- java.lang.illegalStateException:org.jruby.exceptions.RaiseException : cannot load Java class org.apache.http.client.methods.HttpRequestBase

I'm working with logstash 6.2.2 .I tried the 6.2.4 release but same problem.


(Ry Biesemeyer) #2

How are you acquiring Logstash? Are you building from source, or did you download a package? If so, which package (and, did you use a package manager like dpkg, apt, or yum)?

  • what version of Java?
    java -version
    
  • is JAVA_HOME set?
    echo $JAVA_HOME
    
  • what operating system?

(belhadj) #3

Hello
I'm using windows 7.

I have downloaded logstash 's zip file. Unziped it and run it via the command line. Also my JAVA_HOME is well set.

Ps : logstash have been working perfectly fine for two months so i know its not a configuration issue.


(Ry Biesemeyer) #4

does the error indicate in any way that it is coming from a plugin (e.g., an input, output, or filter) that you are using, and if so, have you made any recent changes to your pipeline configuration to invoke new plugins? You may need to pass the --log.level=debug flag when starting Logstash to get it to give you backtraces.

If the error is coming from a plugin, knowing which version of the plugin will help us replicate:

bin/logstash-plugin list --verbose

(belhadj) #5

hello
actually i didn't do anything to my configuration and tried uninstalling and reinstlling my plugins .i think the problem was with my Java.

I formatted my pc and reconfigured everything and its working fine. Thank you for your time.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.