Problem With logstash output email plugin

Could you help me with this error on my logstash 5.3 ?

couldn't find any output plugin named 'email'.


Could you please provide your configuration.
and did you followed this link while making the configuration

Thanks you your Answers.

Yes I followed this link.

This is my configuration:
output {
elasticsearch {
hosts => "localhost:9200"

    stdout {
            codec => rubydebug

email {
to => ""
body => "%{message}"
subject => "Alerte Logs"


Could you please provide the logs and also make sure enable debug mode and then provide the logs

This is the log appeared on the console:

[2017-05-03T11:51:15,205][ERROR][logstash.agent ] Cannot load an invalid configuration {:reason=>"Couldn't find any output plugin named 'email'. Are you sure this is correct? Trying to load the email output plugin resulted in this error: Problems loading the requested plugin named email of type output. Error: NameError NameError"}

How to have the logs without debug?


It is strange. Elastic team has to answer this question.

How to have the logs without debug?

You can change log.level: info in logstash.yml file so that you will not see debug logs.

One thing i can suggest you. whenever you make configuration follow some order.. Always elasticsearch configuration should be in last in output section.

Also when you are using email you should use smtp configuration because without having SMTP port i dont think you can trigger the mails.

Have you tried installing the email output plugin using the instructions in the documentation?

Hello @Raja1 ,

I tried your suggestions but the same error is always present.

Thanks you for your help.

Hello @magnusbaeck,

Yes I tried and I followed this link :



I find the solution to the problem.

Elastic stack 5.4 does not have a default email plugin. There is a way to install it so that it works:

bin/logstash-plugin install logstash-output-email



Hi Baco,

I am getting this error

ERROR: File /usr/share/logstash/Gemfile does not exist or is not writable, aborting

While try this command

bin/logstash-plugin install logstash-output-email

Hello @shubham.iot

I had not this error when I tried this command but I think you are privileges problem for the users.

Are you verify if logstash-plugin exist in bin and if the user has the privilege to run it?

Hi @Baco @magnusbaeck

Thanks for your reply. It really matters a lot for me.

I verified logstash-plugin exists in bin folder in /usr/share/logstash/.
I don't know how to check the user privilege but I gave all the permissions by using this command

sudo chmod 777 /usr/share/logstash

and used this also

$ cd /usr/share/logstash
$ sudo chmod 777 ./bin/logstash-plugin

I still getting the same error :

ERROR: File /usr/share/logstash/Gemfile does not exist or is not writable, aborting

I have one more question also how you start elasticsearch, logstash and kibana?
Like I start elasticsearch by using this sudo /etc/init.d/elasticsearch start
and I start kibana by using this sudo /etc/init.d/kibana start
but while doing same for logstash I get this error:
sudo: /etc/init.d/logstash: command not found

I don't know whenever I start logstash as a service using this command
sudo systemctl start logstash.service
I didn't get any back message from terminal. I am using systemctl becuase I am on ubuntu 16.0.4. using latest version of all ELK.

Hello @shubham.iot

For your error when install logstash-output-email, I have no idea and advice you to do some search on google and to open a new topic. Perhaps someone had a same problem.

To start elasticsearch, take a look at theses links:


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.