Proxy settings for http_poller

Hi,

I am using http_poller input plugin in Logstash to monitor few url's. I am able to monitor the url's that are hosted on my local. I mean, anything with localhost, I'm able to connect using http_poller. Anything on internet I wasn't able to connect initially, but then later when I added proxy settings I was able to connect the url's available on internet as well.

input {
  http_poller {
    urls => {
      ES => "http://localhost:9200"
    }
    request_timeout => 60
    schedule => { "every" => "10s"}
    codec => "json"
    metadata_target => "http_poller_metadata"
  }
  http_poller {
    urls => {
      "Google" => "https://www.google.com"
      "Outlook" => "https://outlook.office365.com/owa/"
      "Internal URL" => "Organizations Internal URL"
    }
    request_timeout => 60
    tags => website_healthcheck
    schedule => { "every" => "10s"}
    proxy => { host => "organization proxy url" port => 8080 scheme => "http" user => "..." password => "..."}
    metadata_target => "http_poller_metadata"
  }
}

I am not able to connect to the Internal URL that's mentioned in the above config. Usually by adding this proxy url in my chrome proxy settings, I am not able to open this Internal URL. In chrome proxy settings, I will add both proxy settings + I will add Internal URL host as an exception to not to use proxy server for this URL, and then I will be able to open this URL in browser. Can you please assist in getting connected to the Internal URL via http_poller !