PV not attaching to Elasticsearch pod

Hi All,

I am facing an issue i.e PV is not getting attached/mounted to Elasticsearch pod.


I have setup Elasticsearch cluster using eck operator. Details are as follows. Cluster is setup in OKE(Oracle kubernetes engine).

ES Version: 6.8.21
Master Nodes: 3
Data nodes 9

Each data node Volume is 500GB.

Everynow and then we are facing issues with storage. Hence I decided to update the storage from 500GB to 750GB.

So I updated the size of PVC of data-0 which updated its respective PV. Then I restarted the data-0 pod however the pod is not going into running state. Then I had manually updated the Block Volume from 500GB to 750 GB and then tried. Same error. Error is follows.


MountVolume.MountDevice failed while expanding volume for volume "<ocid id>" : MountVolume.NodeExpandVolume failed : expandfs command failed, status: Failure, reason: Invalid command; got [/usr/libexec/kubernetes/kubelet-plugins/volume/exec/oracle~oci/oci expandfs {"kubernetes.io/fsType":"ext4","kubernetes.io/pvOrVolumeName":"<ocid id>","kubernetes.io/readwrite":"rw"} /dev/disk/by-path/<redacted> /var/lib/kubelet/plugins/kubernetes.io/flexvolume/oracle/oci/mounts/<ocid-id>]

<ocid-id> -> Oracle cloud identifier similar to ARN in Amazon.

I know this is something related OCI stuff. I just want to know if anyone run into this issue before. Any guidance or help on this?

Hi Elastic team,

Could you please provide your suggestions on this?

I think this init container "elastic-internal-init-filesystem" is trying to prepare the file system and not able to pick up the changes done manually(PVC, PV, Underlying block volume). even after replacing this init container command content with something else(i.e echo "hello") it is not working. Kindly do the needful.

From what I'm reading, volume expansion isn't supported within Oracle's CSI.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.