Running LogStash with Beats as Service, stops with Address in use


(Adrian Martin) #1

I've added --debug to the the rc options and get

{:timestamp=>"2015-12-01T10:26:16.175000+0000", :message=>"Starting Beats input listener", :address=>"0.0.0.0:5044", :level=>:info}
{:timestamp=>"2015-12-01T10:26:16.182000+0000", :message=>"The error reported is: \n  Address already in use - bind - Address already in use"}
{:timestamp=>"2015-12-01T10:32:41.773000+0000", :message=>"Reading config file", :config_file=>"/etc/logstash/conf.d/beat.conf", :level=>:debug, :file=>"logstash/agent.rb", :line=>"325", :method=>"local_config"}

so it wont run as a service.....

there is only one file in conf.d...and it runs fine from the command line...

do I need to specify the machines fqn in the beats input?


(Tudor Golubenco) #2

Can you check if you have something else that is listening on the same port? In Linux that would be:

netstat -nlp | grep 5044

(Adrian Martin) #3

was trying netstat, but didn't have those options(nlp)...

this is what I get

tcp6 0 0 :::5044 :::* LISTEN 12428/java


(Adrian Martin) #4

hmmm so that proc seems to be Logstash Agent....so it's running, are there any docs about the agent?


(system) #5