Sending Logstash's logs to /home/wangyufeng/logstash-5.5.2/logs which is now configured via log4j2.properties ERROR: No configuration file was specified. Perhaps you forgot to provide the '-f yourlogstash.conf' flag?


(Alice) #1

Elasticsearch version: 5.5.2
OS: Linux
Logstash: 5.5.2

When I use the command "./logstash" ro start logstash, it throws such a expception:

SZX1000355659:/home/wangyufeng/logstash-5.5.2/bin # ./logstash
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.
Sending Logstash's logs to /home/wangyufeng/logstash-5.5.2/logs which is now configured via log4j2.properties
ERROR: No configuration file was specified. Perhaps you forgot to provide the '-f yourlogstash.conf' flag?
usage:
bin/logstash -f CONFIG_PATH [-t] [-r] [] [-w COUNT] [-l LOG]
bin/logstash --modules MODULE_NAME [-M "MODULE_NAME.var.PLUGIN_TYPE.PLUGIN_NAME.VARIABLE_NAME=VALUE"] [-t] [-w COUNT] [-l LOG]
bin/logstash -e CONFIG_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]
bin/logstash --help

Can anyone give me some advice?


(Mark Walkom) #2

Did you pass this flag?


(Alice) #3

But when I run the command: "bin/logstash -e 'input{stdin{}}output{stdout{codec=>rubydebug}
}'", it still throws a error:

ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.
Sending Logstash's logs to /home/wangyufeng/logstash-5.5.2/logs which is now configured via log4j2.properties

I have no idea about this, any advice is appreciated.


(Mark Walkom) #4

That's an error, but you can ignore it.


(Alice) #5

Ok, thanks a lot.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.