Setting "dead_letter_queue.enable" hasn't been registered


#1

I'm reading a little the docs, want to optimize my indexing and I think the setting dead_letter_queue.enable: true would be useful.

So I added this line to my logstash.yml, started the service but got the error:

`[2017-07-28T12:10:01,874][FATAL][logstash.runner          ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "dead_letter_queue.enable" hasn't been registered>, :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:29:in `get_setting'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:61:in `set_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:80:in `merge'", "org/jruby/RubyHash.java:1342:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:80:in `merge'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:129:in `validate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:217:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:185:in `run'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:71:in `(root)'"]}`

Do you have any suggestions?

Thanks!
M


(Christian Dahlqvist) #2

Which version of Logstash and the Elasticsearch output plugin are you using?


#3

5.4.0 both


(Christian Dahlqvist) #4

The dead letter queue functionality was introduced in version 5.5.0, so you will need to upgrade to use it.


#5

ok, tnx for the info!


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.