Setting the data_stream.namespace

I've seen numerous posts for folks requesting how to set the data_stream.namespace in the apm-server.yml, but I dont think any have a response. They've all been closed after 20 days, so attempting to ask that same question again:

how do we set data_stream.namespace in the apm-server.yml ?

Thank you,

Hi @Kevin_Patterson Welcome to the community.

Is this what you are looking for?

APM Server binary



Namespace (Integration settings > Advanced options)

That is what I'm looking for but that doesn't seem to work....My v7 related APM had a setup like so:

    - index: "apm-%{[observer.version]}-%{[]}-transaction-000001"
        processor.event: "transaction"

But using the equivalent with the data_stream it seems that namespace does not get set....

even using:

      namespace: testnamespace

I still see only the default getting used.

Apologies I should have asked exactly what version APM server?

And Binary or Fleet Managed?

Looks like that setting became available in 8.8

I'm using 8.5.3 Binary.

If/Can I use a newer APM (8.8) with the 8.5.3 server ?

No, Although it may / may not work ... Other components should not be "ahead" of Elasticsearch.

Elasticsearch should be equal to or ahead of the other components. Kibana and Elasticsearch should always be at the same version.

1 Like