Setting up apm-server

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

TIP 1: select at least one tag that further categorizes your topic. For example server for APM Server related questions, java for questions regarding the Elastic APM Java agent, or ui for questions about the APM App within Kibana.

TIP 2: Check out the troubleshooting guide first. Not only will it help you to resolve common problems faster but it also explains in more detail which information we need before we can properly help you.

Kibana version: 7.10.2

Elasticsearch version: 7.10.2

APM Server version: 7.10.2
APM Agent language and version: node

Browser version:

Original install method (e.g. download page, yum, deb, from source, etc.) and version: RPM

Fresh install or upgraded from other version? fresh

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc. Using logstash & filebeat of same version

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

Steps to reproduce:

  1. Installation(on amazon-linux machine in same VPC):

curl -L -O https://artifacts.elastic.co/downloads/apm-server/apm-server-oss-7.10.2-x86_64.rpm
sudo rpm -vi apm-server-oss-7.10.2-x86_64.rpm

  1. Configured apm-server.yml with output.elasticsearch (including hosts/username/pwd). Elasticsearch being hosted on aws.

  2. Getting error:
    ERROR [pipelines] pipeline/register.go:48 Pipeline registration failed for apm_user_geo.

Even tried by configuring --> pipeline: "_none" in yml file. No change in error!

Hi @divnoor_singh ,
you seem to be trying to set up a fairly outdated version of the apm server, 7.10.2 was released roughly 2 years ago. I highly recommend trying a newer version, for which we still release patch fixes. Is it feasible for you to try out 8.6, or if you'd like to stay on major version 7, 7.17?

Thanks @simitt for replying.
Like I mentioned, my elasticsearch and kibana version is 7.10.2. Is it not mandatory to have apm-server of same version?
Otherwise I can try other version of 7.x

Hey @simitt. I have tried installing apm-server of version 7.17.2, keeping everything same. It's giving me compatibility error, as predicted:(

Sorry for being unclear, I meant whether it is feasible to update the whole stack to a more recent version.