I got the config below but filebeat is ignoring the custom name I want to set for the index and instead puts everything into filebeat-*. I followed the Docs but apparently that information is incorrect.

If have also tried putting the settings under setup.template.settings but that doesn't work either.

  # Array of hosts to connect to.
  hosts: [""]
  output.elasticsearch.index: "awsfilebeat-%{[agent.version]}-%{+yyyy.MM}" "awsfilebeat"
  setup.template.pattern: "awsfilebeat-*"

Kibana visualization settings are also ignored except for, that one works.

  host: "localhost:5601"
  setup.dashboards.index: "awsfilebeat-*" "infra"

Under template settings the replicas setting is ignored as well.
index.number_of_replicas: 0

What is the correct place to put the settings above? W

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.