Single line files - no newline

I have a single line logfile with no newline character that is not being shipped.

I am aware that this is problematic from both searches here on the forums and some trial and error. With that being said, I don't have the option to change this behavior at the moment so I expect to continue to have single line logs with no newline character.

I've tried close_eof: true and setting close_timeout: 1s, but the issue is not the harvesting of the files - it's that filebeat does not ship the log until a newline is found. Aside from running a sed job on every file that lands and inserting a newline (current solution), is there a way to force filebeat to read to the end of the file and then consider the log complete and ship it?

Edit: this is using the 7.7.0 release of filebeat, but it happens with older releases as well.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.