SNMP input with MIB

I´m trying to setup an snmp polling function in our Elasticsearch with Logstash.
Today it is an "Proof of Concept" with only one 4G router from the vendor named Advantech.
I have followed the instructions found at Elastic and converted a MIB file from Advantech to an .dic using libsmi.
the Input configuration at the pipeline for this PoC is quite simple.

" snmp {
walk => ["."]
hosts => [ { host => "udp:" community => "public" version => "2c" retries => 3 } ]
mib_paths => ["/Elastic/logstash/config/MIB/conel/CONEL-MIB.dic"]
tags => ["nodes"]
interval => 10

My issue is that I get this error when I start Logstash.
"[2021-12-22T12:27:02,597][ERROR][logstash.javapipeline ][SNMP-POC] Pipeline error {:pipeline_id=>"SNMP-POC", :exception=>#<LogStash::SnmpMibError: error parsing mib dic file: /Elastic/logstash/config/MIB/conel/CONEL-MIB.dic, error: (eval):1: invalid multibyte char (UTF-8)"

Any ideas on why I get this error?"

My guess it that something went wrong with the conversion and there is a UTF-8 character in the dic file that is not being expected.
Can you link the MIB file? I'd like to try it as well.

I have tried converting 2 MIB files but get the same error, I am sending the link for these MIB files now.
Hope you can find something that I could not


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.