SNMP Trap listener died?

Dear logstash,

when i start logstash ,I got the error msg as follow,

/opt/logstash/bin/logstash -f /etc/logstash/conf.d/logstash-snmptrap.conf -d

SNMP Trap listener died {:exception=>#<Psych::SyntaxError: (): mapping values are not allowed here at line 7 column 19>, :backtrace=>["org/jruby/ext/psych/PsychParser.java:228:in parse'", "/opt/logstash/vendor/jruby/lib/ruby/1.9/psych.rb:375:inparse_stream'", "/opt/logstash/vendor/jruby/lib/ruby/1.9/psych.rb:323:in parse'", "/opt/logstash/vendor/jruby/lib/ruby/1.9/psych.rb:250:inload'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/mib.rb:164:in load_module'", "org/jruby/RubyIO.java:1183:inopen'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/mib.rb:163:in load_module'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/manager.rb:699:inload_modules'", "org/jruby/RubyArray.java:1613:in each'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/manager.rb:699:inload_modules'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/manager.rb:622:in initialize'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-snmptrap-2.0.2/lib/logstash/inputs/snmptrap.rb:74:inbuild_trap_listener'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-snmptrap-2.0.2/lib/logstash/inputs/snmptrap.rb:78:in snmptrap_listener'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-snmptrap-2.0.2/lib/logstash/inputs/snmptrap.rb:53:inrun'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.1.3-java/lib/logstash/pipeline.rb:206:in inputworker'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.1.3-java/lib/logstash/pipeline.rb:199:instart_input'"], :level=>:warn}

What's your configuration? Are you setting the yamlmibdir option? The error message certainly suggests that there's something wrong with line 7 of some of the files in that directory.